SIP Ext GW problem

A H323 and SIP forum only !
MartinB
Member
Posts: 58
Joined: 16 Mar 2011 03:30

SIP Ext GW problem

Post by MartinB » 06 Jun 2018 07:42

HI guys

I need some assistance with SIP External gateway.

I have 2 VOIP providers on the PABX. Different SIP gateway setups. One works and the other one doesn't.

The problematic one authenticates on username and password, and only allows numbers within their number range in correct format.

There are speech problems.
If there is speech the call cuts after 20 seconds. When there is no speech the call cuts after 5 seconds.
On both traces I can see I am not getting a 200 OK from them, indicating the call is established. They can not tell me why. And I suppose that is why the call cuts and eventually then gives congestion.

From IP phone Every second or third call has speech. When connecting on Analog phone there is speech every time but call also cuts.
On incoming call there is one way speech.

My IP domain is on G7.29. I have supplied them with all RTP ports but they say they are allowing all RTP traffic at the moment but will set up QOS for the RTP ports on the router.

The VOIP provider has the attitude of their equipment works and I need to fix my problem.
Every time I make a few changes on my sip Gateway to test and run traces they block my IP address for 30 minutes.

Can someone please assist?

Please note there are 6 sip gateways on this pabx so on the trace there is registration 200 ok message.

Martin
You do not have the required permissions to view the files attached to this post.

User avatar
cavagnaro
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 6937
Joined: 14 Sep 2005 19:45
Location: Brasil, Porto Alegre
Contact:

Re: SIP Ext GW problem

Post by cavagnaro » 06 Jun 2018 09:34

Hey Martin
But which register should we look at?

No audio is the lack of rtp, so or they are not sending it or your firewall (?)(SBC?) is blocking it.

Check the SDP used and verify those UDP ports are opened. Remember RTP is UDP and not TCP.


Enviado de meu E6633 usando o Tapatalk

Ignorance is not the problem, the problem is the one who doesn't want to learn

OTUC/ICS ACFE/ACSE R3.0/4.0/5.0/6.0
Certified Genesys CIV 8.5
Certified Genesys Troubleshooting 8.5
Certified Genesys BEP 8.x
Genesys Developer

MartinB
Member
Posts: 58
Joined: 16 Mar 2011 03:30

Re: SIP Ext GW problem

Post by MartinB » 06 Jun 2018 10:23

HI Cavagnaro

Thank you for replying.

Its this register.

"P-Asserted-Identity: "Test" <sip:27113969540@27113969540.hytec2.stdsiptrunk.telkom;user=phone>
Content-Type: application/sdp
To: <sip:0784196110@27113969540.hytec2.stdsiptrunk.telkom;user=phone>
From: "Test" <sip:27113969540@27113969540.hytec2.stdsiptrunk.telkom;user=phone>;tag=0cea45f2d344175a34f3afb6cea36a5c

There is a Cisco Router between my pabx and the VOIP provider. The VOIP provider assures me they are listening on all RTP ports and the company who set up the cisco router assures me that they are allowing all RTP traffic. I have supplied them with a list of all Ports used according to TC1235.

I know it has to be RTP ports somewhere. From what I could read on another traces the traffic was on udp ports 32514,32515,57348,57349 and 32696 but they say they are allowing all rtp traffic.

I know its not the pabx as I have another SIP account to different provider that works fine but I am struggling to prove to them they are at Fault.

I have other traces as well if that would help?

User avatar
cavagnaro
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 6937
Joined: 14 Sep 2005 19:45
Location: Brasil, Porto Alegre
Contact:

Re: SIP Ext GW problem

Post by cavagnaro » 06 Jun 2018 10:46

Can you ask Cisco to do a port mirror from all traffic coming from that provider to some other interface so you capture it with a Wireshark?


Enviado de meu E6633 usando o Tapatalk

Ignorance is not the problem, the problem is the one who doesn't want to learn

OTUC/ICS ACFE/ACSE R3.0/4.0/5.0/6.0
Certified Genesys CIV 8.5
Certified Genesys Troubleshooting 8.5
Certified Genesys BEP 8.x
Genesys Developer

MartinB
Member
Posts: 58
Joined: 16 Mar 2011 03:30

Re: SIP Ext GW problem

Post by MartinB » 06 Jun 2018 11:49

Okay will ask them tomorrow morning to do that and then I will post it?
Thank you.

User avatar
cavagnaro
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 6937
Joined: 14 Sep 2005 19:45
Location: Brasil, Porto Alegre
Contact:

Re: SIP Ext GW problem

Post by cavagnaro » 06 Jun 2018 11:51

You can post or check it yourself. You can listen the audio and see if there are audio both ways or just one.
If one, there is your proof provider is the issue.
If both, provider is ok and your router is blocking something.


Enviado de meu E6633 usando o Tapatalk

Ignorance is not the problem, the problem is the one who doesn't want to learn

OTUC/ICS ACFE/ACSE R3.0/4.0/5.0/6.0
Certified Genesys CIV 8.5
Certified Genesys Troubleshooting 8.5
Certified Genesys BEP 8.x
Genesys Developer

MartinB
Member
Posts: 58
Joined: 16 Mar 2011 03:30

Re: SIP Ext GW problem

Post by MartinB » 06 Jun 2018 14:06

Okay thank you

I tried mirror function on IP phones here but it does not seem to work on either rel 12.1 or it might be the new instruments 8028s.
All my Parametres in 8&9 series is set correctly. ( State PC Port + Cascad. not filt. (IP-Phone or PC))

wanted to run wireshark on my phone port.

But will send update after I managed to get a trace with all provider traffic.

User avatar
cavagnaro
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 6937
Joined: 14 Sep 2005 19:45
Location: Brasil, Porto Alegre
Contact:

Re: SIP Ext GW problem

Post by cavagnaro » 06 Jun 2018 14:10

Have you done the telnet procedure to enable the mirror?

Enviado de meu E6633 usando o Tapatalk

Ignorance is not the problem, the problem is the one who doesn't want to learn

OTUC/ICS ACFE/ACSE R3.0/4.0/5.0/6.0
Certified Genesys CIV 8.5
Certified Genesys Troubleshooting 8.5
Certified Genesys BEP 8.x
Genesys Developer

MartinB
Member
Posts: 58
Joined: 16 Mar 2011 03:30

Re: SIP Ext GW problem

Post by MartinB » 07 Jun 2018 04:16

Yes I tried both ways. Via ippstat menu/option 15/time set

and ippstat telnet d XXX t 1440

Neither work so I cannot set the mirror function on the port

User avatar
cavagnaro
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 6937
Joined: 14 Sep 2005 19:45
Location: Brasil, Porto Alegre
Contact:

Re: SIP Ext GW problem

Post by cavagnaro » 07 Jun 2018 08:21

You doing the telnet from the OXE, right?

Enviado de meu E6633 usando o Tapatalk

Ignorance is not the problem, the problem is the one who doesn't want to learn

OTUC/ICS ACFE/ACSE R3.0/4.0/5.0/6.0
Certified Genesys CIV 8.5
Certified Genesys Troubleshooting 8.5
Certified Genesys BEP 8.x
Genesys Developer

Post Reply

Return to “H323 / Sip”