BGP Multivendors (CISCO)

Post Reply
fla
Member
Posts: 2
Joined: 19 Feb 2020 20:44

BGP Multivendors (CISCO)

Post by fla »

Hi guys.

I created a lab on GNS3 to develop an initial BGP LAB. With 2 Cisco PE's 7200 and 7750 with P.
The settings below each router.

My problem is that R1-PE does not ping R2-PE.

How do I advertise the interface from R1-PE to R2-PE and R2-PE to R1-PE?

R1-PE
interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/0
ip address 86.191.16.9 255.255.255.252
duplex half
!
router bgp 65001
no synchronization
bgp router-id 10.10.10.1
bgp log-neighbor-changes
neighbor 86.191.16.10 remote-as 65001
neighbor 186.191.16.9 remote-as 65001
no auto-summary

R2-PE
interface Loopback0
ip address 10.10.10.3 255.255.255.255
!
interface FastEthernet0/0
ip address 186.191.16.9 255.255.255.252
duplex half
!
router bgp 65001
no synchronization
bgp router-id 10.10.10.3
bgp log-neighbor-changes
neighbor 186.191.16.10 remote-as 65001
neighbor 86.191.16.9 remote-as 65001
no auto-summary

R2-P

#--------------------------------------------------
echo "Router (Network Side) Configuration"
#--------------------------------------------------
router
interface "To_PE-R1_Fa0/0"
address 86.191.16.10/30
port 1/1/1
no shutdown
exit
interface "To_PE-R2_Fa0/0"
address 186.191.16.10/30
port 1/1/2
no shutdown
exit
interface "lo0"
address 10.10.10.2/32
loopback
no shutdown
exit
interface "system"
no shutdown
exit
autonomous-system 65001
#--------------------------------------------------

configure router autonomous-system 65001
configure router bgp
group "IBGP"
neighbor 186.191.16.9
description PE-R2
exit
neighbor 86.191.16.9
description PE-R1
exit
fla
Member
Posts: 2
Joined: 19 Feb 2020 20:44

Re: BGP Multivendors (CISCO)

Post by fla »

I needed to use the update-source command to tell BGP to source the update from the loopback
interface.
PE-R2(config-router)#neighbor 10.10.10.1 remote-as 65001
and
PE-R1(config-router)#neighbor 10.10.10.2 remote-as 65001

Other stuff. I change ip address loopback 0 in A:Nokia-P# and PE-R2.
show
interface "lo0"
address 10.10.10.10/32
loopback
no shutdown
exit

interface Loopback0
ip address 10.10.10.2 255.255.255.255
!

I still need help, being able to announce the loopback on PE-R2 for PE-R1 and PE-R1 for PE-R2
Stoffen
Member
Posts: 147
Joined: 23 May 2014 05:32
Location: Norway

Re: BGP Multivendors (CISCO)

Post by Stoffen »

Hi.
First of all, you should use router interface system on 7750 as you would use the loopback 0 on 7200.
The interface system is used in a lot of usecases when it comes to how SROS is built.
So, strong recommendation to delete the "lo0" on SROS and enable this address in if "system" instead.

Since you are doing a iBGP session, remember the iBGP split-horizon rule: an iBGP peer will never advertise to another iBGP peer what it has learned from an iBGP peer.
In your topology: PE-P-PE, I would go with iBGP between PE's, and leave the core (P) BGP free.
If you still want P to participate in BGP, you also need to add the PE-PE iBGP neighbor to ensure the full-mesh required for iBGP to work.
Or you could make the P router a route-reflector.
Use an IGP (ISIS/OSPF) to redistribute the /32 loopback/system adresses through the IGP.

To advertise routes into BGP, you need to use a policy.

configure router policy-options
begin
prefix-list Direct2BGP
prefix <prefix>/<len> exact/longer/ ... some various options here..
exit
policy-statement Direct2BGP
entry 10
from
protocol direct
prefix-list Direct2BGP
exit
action accept
exit
exit
commit

configure router bgp
group iBGP
export Direct2BGP
[flash=]
Christoffer

Network System Expert Norway
Nokia SRA #265
Alcatel-Lucent SRC 3RP Certified #552
Alcatel-Lucent SRC NRS-2 Certified #1104
Huawei HCNP Routing & Switching certified
Cisco CCNP Certified
LinkedIN
[/flash]
Post Reply

Return to “7750 SR”