Errors after removing one of the two default gateways.

Post Reply
donovan2123
Member
Posts: 4
Joined: 03 May 2018 06:59

Errors after removing one of the two default gateways.

Post by donovan2123 » 16 May 2018 05:03

Hi all,

Wondering if someone can help me diagnose an issue. we have a 6800 which has 2 static default gateways. One with metric 1 and the other with metric 15. We know both gateways work as if we manually set a PC to use either of the two it works and breaks out to WAN.

Anyways we removed the lower cost metric which was metric 1 and it stopped routing to WAN even though there was another default gateway present with metric 15.

see errors below, It is a strange one as we did the exact same thing at another site and it worked perfectly. As you can see at the bottom of the log it shows we added the metric 1 route back in which fixed issue but does not explain why what I did would not work?

The two default GW are as follows:
ip static-route 0.0.0.0/0 gateway 10.1.0.224 metric 1 (This is the one we removed)
ip static-route 0.0.0.0/0 gateway 10.1.0.231 metric 15

Code: Select all

May 12 12:59:30 "Switch Name" swlogd: SES CMD alarm(1) CLI log, user: admin (10.1.12.65), cmd: no ip static-route 0.0.0.0/0 gateway 10.1.0.224 metric 1, result: SUCCESS
May 12 12:59:42 "Switch Name" swlogd: ChassisSupervisor SharedMem Sync info(5) SMSyncUpdateCMMVer1: 2/0 oper status change from 4 to 0
May 12 12:59:52 "Switch Name" swlogd: ChassisSupervisor SharedMem Sync info(5) SMSyncUpdateCMMVer1: 2/0 oper status change from 4 to 0
May 12 13:00:12 "Switch Name" swlogd: ChassisSupervisor SharedMem Sync info(5) SMSyncUpdateCMMVer1: 2/0 oper status change from 4 to 0
May 12 13:00:20 "Switch Name" swlogd: vcmCmm ipc info(5) CMM:vcmCMM_server_rx@1358: Process (protOperData, len 96, src 0/65/33381)
May 12 13:00:20 "Switch Name" swlogd: vcmCmm ipc info(5) CMM:vcmCMN_tx_data_cb@3076: distribChassisStatus2NI -> (chassis 0, Slot 1, port 17653, len 96)
May 12 13:00:20 "Switch Name" swlogd: vcmNi ipc info(5) NI:vcmNI_peer_cmm_ni_rx@836: Process msg (distribChassisStatus2NI, len 96, src 0/65)
May 12 13:00:22 "Switch Name" swlogd: ChassisSupervisor SharedMem Sync info(5) SMSyncUpdateCMMVer1: 2/0 oper status change from 4 to 0
May 12 13:00:42 "Switch Name" swlogd: ChassisSupervisor SharedMem Sync info(5) SMSyncUpdateCMMVer1: 2/0 oper status change from 4 to 0
May 12 13:00:52 "Switch Name" swlogd: ChassisSupervisor SharedMem Sync info(5) SMSyncUpdateCMMVer1: 2/0 oper status change from 4 to 0
May 12 13:01:06 "Switch Name" swlogd: MIP_GATEWAY mipgwd alert(3) ---- Logging MIP_SET type, command to be sent:
May 12 13:01:06 "Switch Name" swlogd: MIP_GATEWAY mipgwd alert(3) MIP_SET(4) msg_id(145031192) (APPID_CLI(67/0) -> APPID_DRC_IPRM_VRF(125)) values:
May 12 13:01:06 "Switch Name" swlogd: MIP_GATEWAY mipgwd alert(3) Table(75804/0): alaIprmStaticRouteTable
May 12 13:01:06 "Switch Name" swlogd: MIP_GATEWAY mipgwd alert(3)  Index: 0 0 0 0 0 0 0 0 10 1 0 224 
May 12 13:01:06 "Switch Name" swlogd: MIP_GATEWAY mipgwd alert(3)   Object(4) Name: alaIprmStaticRouteMetric
May 12 13:01:06 "Switch Name" swlogd: MIP_GATEWAY mipgwd alert(3)    Object Value(uint32): 1
May 12 13:01:06 "Switch Name" swlogd: MIP_GATEWAY mipgwd alert(3)   Object(7) Name: alaIprmStaticRouteType
May 12 13:01:06 "Switch Name" swlogd: MIP_GATEWAY mipgwd alert(3)    Object Value(uint32): 1
May 12 13:01:06 "Switch Name" swlogd: MIP_GATEWAY mipgwd alert(3)   Object(5) Name: alaIprmStaticRouteStatus
May 12 13:01:06 "Switch Name" swlogd: MIP_GATEWAY mipgwd alert(3)    Object Value(uint32): 4
May 12 13:01:06 "Switch Name" swlogd: MIP_GATEWAY mipgwd alert(3) ----------------
May 12 13:01:06 "Switch Name" swlogd: SES CMD alarm(1) CLI log, user: admin (10.1.12.65), cmd: ip static-route 0.0.0.0/0 gateway 10.1.0.224 metric 1, result: SUCCESS
Last edited by donovan2123 on 16 May 2018 06:24, edited 1 time in total.

devnull
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 922
Joined: 07 Sep 2010 10:16
Location: Germany

Re: Errors after removing one of the two default gateways.

Post by devnull » 16 May 2018 05:59

Logs don't show anything .. there is no error - the alerts seem to be related to readding the route.

What is in your routing table after removing the lower metric device? it is visible? it is reachable?

Normaly if you remove the lower metric gateway, the other on should "appear" and therfore be used. At anytime active will be just the better one (the lower metric in case of both routes)

Of cause if the Interface where the second gateway is located is down it will not work.

donovan2123
Member
Posts: 4
Joined: 03 May 2018 06:59

Re: Errors after removing one of the two default gateways.

Post by donovan2123 » 16 May 2018 06:24

devnull wrote:
16 May 2018 05:59
Logs don't show anything .. there is no error - the alerts seem to be related to readding the route.

What is in your routing table after removing the lower metric device? it is visible? it is reachable?

Normaly if you remove the lower metric gateway, the other on should "appear" and therfore be used. At anytime active will be just the better one (the lower metric in case of both routes)

Of cause if the Interface where the second gateway is located is down it will not work.

Hi,
Seconds after posting this I realized how the logs works, The CLI command appears on the log after the command has been actioned. Yes - Routing table looked fine with the one default route visible. On further thinking I reckon the problem was next hop related as I can not see why this would of not worked. Unfortunately I do not provide the firewall so rely on the firewall provider. Will run some traces when we reapply the changes. Thanks

Post Reply

Return to “OmniSwitch 6800”