Impossible to update Omnivista from 4.1.08.00c to 4.2.10.02b

Post Reply
fdurante
Member
Posts: 63
Joined: 27 Nov 2007 06:28

Impossible to update Omnivista from 4.1.08.00c to 4.2.10.02b

Post by fdurante » 11 Sep 2008 12:01

I have an old version of Omnivista server 4.1.08.00c with licence .sw4760 version 9.
I received a new licence .sw4760 (but in version 10) with a new functionnality.
This new licence .sw4760 is not compatible with the old version of Omnivista server 4.1.08.00c.
So, I have to update Omnivista version to 4.2.10.02b and I restart "ServerSetup.exe" of this new version.
Then, I include the path to the new licence .sw4760 (version 10) -> all the fields are valid
And the update is started.

After “Install Progress”, an error window is displayed :

------------------------------------------------
Interactive SQL

Error at line 1
Specified database file already in use
------------------------------------------------

And when I click on “OK”, the rollback is applied to interrupt Omnivista installation.

At the end of failed update, I click on “view log file” and the following messages are displayed :

== 2008/09/11 12:17:59 ====================
Full log file: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\2\OmniVista4760_install.log
Installing version 4.2.10.02
Upgrading from 4.1.08.00
== 2008/09/11 12:18:21 ====================
Action: Stop server SNMP
Action: copy old params.st and stylev1.css to temp
Action: Stop Service Manager service
Action: Stop database server
Action: Stop LDAP directory server
Action: Stop LDAP administration server
== 2008/09/11 12:18:58 ====================
Action: Create missing directories
Action: Replace strings in directory url file
Action: Installation of httpd
Action: Installation of php
Action: Configuring httpd
Action: Override php.ini
Action: Configuring php
Action: Configure firewall
Action: Replace strings in firewall configuration scripts
Action: Copy 4760 LDAP schemas in C:\4760\Netscape\server5slapd-4760\config\schema
Action: Start LDAP administration server
Action: Start SunONE directory server
Action: Backuping LDAP content for technical support.
Action: Replace strings scheduler LDIF files.
Action: Upgrade version.
Action: Configuration of service ASANYs_nmc50
Action: Start database server
Action: firewall for dbeng9 for upgrade SQL
Action: upgrade ldap from nmc5.4.1.08.00 to nmc5.4.1.09.00
Action: Fix database location in file RestoreContext.ini
Action: upgrade nmc5.db from nmc5.4.1.09.00 to nmc5.4.1.10.00 XTSce81418
FAILURE: upgrade_nmc5.db_4.1.09.00_4.1.10.00


But when I look at the running processes (Ctrl + alt+del and "Task manager") and "services.msc", no process is running for databases (ex : SQL Anywhere or NMC database) and I closed all the Omnivista 4760 client applications.

Did you see this problem before ?
XTSce81418 correspond to an Alcatel bug ? Do you have more details about this bug ? Is it resolved ? Is there a patch ?

wai-hung.yuen
Member
Posts: 2
Joined: 24 Sep 2008 05:30

Re: Impossible to update Omnivista from 4.1.08.00c to 4.2.10.02b

Post by wai-hung.yuen » 24 Sep 2008 06:20

Knightrider wrote: This user has been warned for duplication

[quote="f
fdurante wrote:I have an old version of Omnivista server 4.1.08.00c with licence .sw4760 version 9.
I received a new licence .sw4760 (but in version 10) with a new functionnality.
This new licence .sw4760 is not compatible with the old version of Omnivista server 4.1.08.00c.
So, I have to update Omnivista version to 4.2.10.02b and I restart "ServerSetup.exe" of this new version.
Then, I include the path to the new licence .sw4760 (version 10) -> all the fields are valid
And the update is started.

After “Install Progress”, an error window is displayed :

------------------------------------------------
Interactive SQL

Error at line 1
Specified database file already in use
------------------------------------------------

And when I click on “OK”, the rollback is applied to interrupt Omnivista installation.

At the end of failed update, I click on “view log file” and the following messages are displayed :

== 2008/09/11 12:17:59 ====================
Full log file: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\2\OmniVista4760_install.log
Installing version 4.2.10.02
Upgrading from 4.1.08.00
== 2008/09/11 12:18:21 ====================
Action: Stop server SNMP
Action: copy old params.st and stylev1.css to temp
Action: Stop Service Manager service
Action: Stop database server
Action: Stop LDAP directory server
Action: Stop LDAP administration server
== 2008/09/11 12:18:58 ====================
Action: Create missing directories
Action: Replace strings in directory url file
Action: Installation of httpd
Action: Installation of php
Action: Configuring httpd
Action: Override php.ini
Action: Configuring php
Action: Configure firewall
Action: Replace strings in firewall configuration scripts
Action: Copy 4760 LDAP schemas in C:\4760\Netscape\server5slapd-4760\config\schema
Action: Start LDAP administration server
Action: Start SunONE directory server
Action: Backuping LDAP content for technical support.
Action: Replace strings scheduler LDIF files.
Action: Upgrade version.
Action: Configuration of service ASANYs_nmc50
Action: Start database server
Action: firewall for dbeng9 for upgrade SQL
Action: upgrade ldap from nmc5.4.1.08.00 to nmc5.4.1.09.00
Action: Fix database location in file RestoreContext.ini
Action: upgrade nmc5.db from nmc5.4.1.09.00 to nmc5.4.1.10.00 XTSce81418
FAILURE: upgrade_nmc5.db_4.1.09.00_4.1.10.00


But when I look at the running processes (Ctrl + alt+del and "Task manager") and "services.msc", no process is running for databases (ex : SQL Anywhere or NMC database) and I closed all the Omnivista 4760 client applications.

Did you see this problem before ?
XTSce81418 correspond to an Alcatel bug ? Do you have more details about this bug ? Is it resolved ? Is there a patch ?
durante"]I have an old version of Omnivista server 4.1.08.00c with licence .sw4760 version 9.
I received a new licence .sw4760 (but in version 10) with a new functionnality.
This new licence .sw4760 is not compatible with the old version of Omnivista server 4.1.08.00c.
So, I have to update Omnivista version to 4.2.10.02b and I restart "ServerSetup.exe" of this new version.
Then, I include the path to the new licence .sw4760 (version 10) -> all the fields are valid
And the update is started.

After “Install Progress”, an error window is displayed :

------------------------------------------------
Interactive SQL

Error at line 1
Specified database file already in use
------------------------------------------------

And when I click on “OK”, the rollback is applied to interrupt Omnivista installation.

At the end of failed update, I click on “view log file” and the following messages are displayed :

== 2008/09/11 12:17:59 ====================
Full log file: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\2\OmniVista4760_install.log
Installing version 4.2.10.02
Upgrading from 4.1.08.00
== 2008/09/11 12:18:21 ====================
Action: Stop server SNMP
Action: copy old params.st and stylev1.css to temp
Action: Stop Service Manager service
Action: Stop database server
Action: Stop LDAP directory server
Action: Stop LDAP administration server
== 2008/09/11 12:18:58 ====================
Action: Create missing directories
Action: Replace strings in directory url file
Action: Installation of httpd
Action: Installation of php
Action: Configuring httpd
Action: Override php.ini
Action: Configuring php
Action: Configure firewall
Action: Replace strings in firewall configuration scripts
Action: Copy 4760 LDAP schemas in C:\4760\Netscape\server5slapd-4760\config\schema
Action: Start LDAP administration server
Action: Start SunONE directory server
Action: Backuping LDAP content for technical support.
Action: Replace strings scheduler LDIF files.
Action: Upgrade version.
Action: Configuration of service ASANYs_nmc50
Action: Start database server
Action: firewall for dbeng9 for upgrade SQL
Action: upgrade ldap from nmc5.4.1.08.00 to nmc5.4.1.09.00
Action: Fix database location in file RestoreContext.ini
Action: upgrade nmc5.db from nmc5.4.1.09.00 to nmc5.4.1.10.00 XTSce81418
FAILURE: upgrade_nmc5.db_4.1.09.00_4.1.10.00


But when I look at the running processes (Ctrl + alt+del and "Task manager") and "services.msc", no process is running for databases (ex : SQL Anywhere or NMC database) and I closed all the Omnivista 4760 client applications.

Did you see this problem before ?
XTSce81418 correspond to an Alcatel bug ? Do you have more details about this bug ? Is it resolved ? Is there a patch ?[/quote]

fdurante
Member
Posts: 63
Joined: 27 Nov 2007 06:28

Re: Impossible to update Omnivista from 4.1.08.00c to 4.2.10.02b

Post by fdurante » 29 Sep 2008 10:42

After disconnecting the network cable and starting the update locally on the server, it's OK !

swinstu
Member
Posts: 163
Joined: 30 Oct 2007 21:37

Re: Impossible to update Omnivista from 4.1.08.00c to 4.2.10

Post by swinstu » 12 Mar 2014 07:44

I also have same issue today, upgraded R5.1 to R5.2 with error message:
Error at line 1
Specified database file already in use. I am also doing upgrade via RDP with admin access.

the server install then rollsback but when i log on using the client, its show the new R5.2 version in help > about.
the client tries to upgrade but I get an error message:
Unable to retrieve upgrade.lst file.

This maybe due to the rollback and not installing all client necessary files to the server. I can connect normally if I click "continue" rather than "upgrade" without any freezing.
I have manually installed client R5.2 but its very buggy and keeps freezes especially when running configuration.

I will try a local install of the 4760 server on Monday, hopefully works without database error message and the client upgrade works as it should.

Host file looks ok and no DNS/IP/Operating system change has been done.
SWINSTU
ACSE OXE R12.1
ACSE 8770 R3.2(4760 R5.x)
ACSE OT R2.3 IP/SIP and UC&C

swinstu
Member
Posts: 163
Joined: 30 Oct 2007 21:37

Re: Impossible to update Omnivista from 4.1.08.00c to 4.2.10

Post by swinstu » 21 Mar 2014 03:26

I had to uninstall and then reinstall the current version R5.1 restore backup then upgrade to to R5.2. All worked well. Realised that Upgrades/installs should not be done via RDP.
SWINSTU
ACSE OXE R12.1
ACSE 8770 R3.2(4760 R5.x)
ACSE OT R2.3 IP/SIP and UC&C

Post Reply

Return to “OmniVista 4760”