4XX8EE Phones with Asterisk

Post Reply
cwsonline
Member
Posts: 76
Joined: 27 Mar 2007 10:18

4XX8EE Phones with Asterisk

Post by cwsonline » 01 Jun 2010 17:54

I have been trying to get the 4XX8EE phones to work with Asterisk but I haven't been able to get to far with this. I may be over thinking this. I have been able to change the mode from NOE to SIP though the telnet session to the phone. At this point the phone repeatedly resets and I am unable to change any of the configuration through the phone. From what I have been able to find in the documentation it is looking for sipconfig.txt and/or sipconfig-macaddress.txt. I can't get the phone to register with an OXE or Asterisk. It just tells me that the config download has failed. Any guidance would be welcome. Thank you.

cwsonline
Member
Posts: 76
Joined: 27 Mar 2007 10:18

Post by cwsonline » 01 Jun 2010 18:25

I am testing with a 4008 so I ftped the binaries (bin4008, datsip4018, and noesip4008) and sipconfig.txt into /tftpboot on Asterisk. I have a feeling I am in the general area of where I need to be but I am clearly missing something.

tincho.rn
Alcatel Unleashed Certified Guru
Alcatel Unleashed Certified Guru
Posts: 929
Joined: 30 Jan 2006 09:40
Location: Argentina
Contact:

Post by tincho.rn » 01 Jun 2010 19:56

IP Touch series 8 use propietary protocol. They support SIP two, but you need a least one binary download from Alcatel-Lucent PBX. Now 4008 and 4018 will arrive full SIP, you should ask for this phones with only SIP stack already working.

I believe ALU will have to send 4008/18 with NOE for thoose who use OXO and 4008/4018 with SIP for thoose witch have OXE and wants to buy SIP user licenses.

Regards.

cwsonline
Member
Posts: 76
Joined: 27 Mar 2007 10:18

Post by cwsonline » 01 Jun 2010 20:37

I have enabled SIP on these phones and from what I have read including technical communications from ALU these should work with Asterisk so I was hoping someone who has done this might be able to give some direction. I have also let them download the latest binaries from the OXE. I think I just don't have the sipconfig managed properly or perhaps not in the right location on Asterisk.

User avatar
Reinoud
Member
Posts: 35
Joined: 12 Feb 2010 03:09
Location: The Netherlands

Post by Reinoud » 19 Jun 2010 18:24

Did you have any luck with this? I'm trying to do the same, but no luck... Had it working once... If you want I'l have a look at the sipconfig.txt. Did you check with wireshark the tftp download?

cwsonline
Member
Posts: 76
Joined: 27 Mar 2007 10:18

Post by cwsonline » 19 Jun 2010 19:06

I have been working on some other things since then but I don't think I had tftp running so now it is either get that running or instead I was thinking of just moving the files then setting the phone to use http since I do know that is running on the Asterisk box.

User avatar
Reinoud
Member
Posts: 35
Joined: 12 Feb 2010 03:09
Location: The Netherlands

Post by Reinoud » 23 Jun 2010 18:04

Did you manage to get it to work?

I'm trying here, but no luck! Getting INVALID PARAMETERS!

User avatar
Reinoud
Member
Posts: 35
Joined: 12 Feb 2010 03:09
Location: The Netherlands

Post by Reinoud » 29 Jun 2010 08:45

I succeeded to get the phone to work! I activated the netlog option, and installed a syslog server. It seems that there were two parameters missing (one without value, and one completely missing). I added these parameters and it started to download and flash the phone. After that it came into service!

User avatar
alspocky
Member
Posts: 3
Joined: 19 Jul 2010 07:18

Post by alspocky » 19 Jul 2010 07:21

I have some 4018 and Asterisk, and I think you just saved my day!!!

Thanks for the info. I will give it a try.

User avatar
alspocky
Member
Posts: 3
Joined: 19 Jul 2010 07:18

Newbie trying to do the same...

Post by alspocky » 19 Jul 2010 07:46

I'm trying to do the same here. I have eight Alcatel-Lucent 4018 VoIP and an Asterisk installed, but I have no idea how to start.

I'm trying to access the configuration files you are mentioning, but with no luck.

Can you help me, please?

Thanks in advance,

alspocky (fgalindo@escolessas.com)

Post Reply

Return to “Asterisk”